Computer stuff

From: william (WILLIAMA)17 Jan 10:57
To: ALL1 of 22
Sometimes computer dabbling can be entertaining for a while. Sometimes not. Because I had an i7 860 (2009 onwards) and 16GB (tbh) of DDR3 plus all the other bits to build a PC, I replaced the failed motherboard of my Plex box with an identical(ish) mobo, an ancient intel thing. This had some odd issues a year back to do with its SATA handling which I "resolved" by swapping one disk to USB. Now the SATA issues have returned to bite me in the backside. 

My method is to have copy drives for each of my plex data disks, so that if one fails I haven't lost several terabytes of films and TV shows. Of course, this isn't perfect, especially if the mechanism in charge of actually writing to the disks starts to get iffy. This seems to have happened now. First I noticed was that all the drives except for the boot drive were missing. I swapped things about but basically the mobo is fine getting to the BIOS, but will only recognise one SATA drive at a time. Plug two in and it doesn't see either. Time for a new mobo. This time I'm not going for 2009, I'll be aiming for a more modern era.

As for the data drives. One was screwed, as in Windows said it had errors. After scan and fix, it had some data, but basically a load of bollocks. Half the films were zero bytes. Others claimed to be, say, Battlestar Galactica but when viewed were chunks of old Marx Brothers movies. The backup drive looks to be fine, as in a random check through and all the films and TV series appear to be there and working. Windows says it has errors, but there's no chance in hell I'm letting it fix them. 

So basically it's a rebuild, plus I've got to see if I can get the contents of the backup drive onto the original data drive. I'm thinking Robocopy is my best bet, although this is likely to take a wet weekend. The slightly better news is that my pair of 8TB drives (data and backup) seem to have survived intact.

Oh, and as it wouldn't be a proper PC problem without some other annoyance, the new board has an 8 pin EATX socket which must have a corresponding plug to work, whereas my PSU, which I only bought 18 months ago! only has a four and a six. The six is plug compatible with the first part of the socket and the first two pins of the four are plug compatible with the remaining two, and as they're all just 12V and neutral I rather hoped I could wangle something, but I only get a few lights so, bugger it, a new PSU as well.
From: milko18 Jan 13:33
To: william (WILLIAMA) 2 of 22
I think I've lost all patience for computer problem solving at the moment. my fucking printer wouldn't print properly and I was fairly close to fetching a hammer for it. Mind you, printers are uniquely frustrating items.
From: william (WILLIAMA)18 Jan 14:46
To: milko 3 of 22
They are aren't they.

The printer is offline/in use/not found. And people who write stuff for printers don't help. Mrs WmA prints a lot from PDFs (she makes clothes and prints patterns) and PDFs can be pigs to print from, especially using a browser to read them. Then there are settings that override other settings so you end up trying to print "letter" size when everything you can see says "A4". It goes on.

From: milko18 Jan 16:05
To: william (WILLIAMA) 4 of 22
Every creative or PDF app has its own printer settings, which sit on top of the manufacturer ones which sit on top of the Windows ones but me phrasing it that way implied a clearer hierarchy than anything can actually tell you for sure. I had one of those subscription inkjet things from HP, which was sort of fine in a "this is probably a rip-off even at the lowest price level" until one day it flashed lights instead of printing. Support amounted to "if you pay £50 we will have a technical support conversation with you" that I had strong suspicions would involve turning it off, on and then deciding it was dead. That's "boycott manufacturer" level to me. So I got an Epson and no subscription and it was fine but the ink is insanely expensive and it complains if you use 3rd party ink but I have at least finally got it to accept and print with it. But even printing (not printing! 3 failed 3rd party cartridges in a row) black text greyscale-mode test prints was running down the YMK cartridges! Then it wouldn't print anything at all until they got replaced as well! God I want to take a hammer to it again now just from reliving this.

I'll probably go laser next time, if we ever want to print in colour we'll take it to a shop or school or something. That's what I almost did this time as well.
From: william (WILLIAMA)19 Jan 00:48
To: milko 5 of 22
The mire of my own IT failures gets deeper. Got my new Plex machine up and working (as a PC, not as a Plex machine just yet) and was pleased to see how Windows 10 happily switched hardware which isn't what I like to do, but it was just a test. Then Microsoft stepped in. You can reactivate through the MS site following a major hardware change. At first it presented a dialog to sign into an MS account from where you pick your MS account linked machine to reactivate. If the machine's not listed eg because you have another MS account and pcked the wrong one (like I did) thn it's a case of trying again. Except the MS activation server went down. MS recommended a restart, only when I did, they had changed the actual PC login from a choice between PIN and local password to PIN and MS account. The wrong one. So I had to switch my account settings back to what they were, just to allow me to log in to the right MS account to reactivate.

Then my boot drive began to fail.

I've also been printing. 
From: CHYRON (DSMITHHFX)22 Jan 12:07
To: william (WILLIAMA) 6 of 22
These aren't *your* IT failures, they are IT failures, full stop. IT as a totality is a spectacular, catastrophic, epic fail that we are completely unequipped to even cope with, let alone 'fix'. Anyway, it has provided a bit of amusement. So there's that.
From: william (WILLIAMA)22 Jan 17:21
Indeed, point taken. Actually, it's all working now with the one exception that Windows won't activate, and I'm not completely sure whether I'm entitled to activation or meant to buy a new license. In the old days, you upgraded your computer either by choice or because of some parts failure and tried your license again. If it didn't work you phoned some poor sod in a call centre who took your story and (99% guaranteed) would generate a new number for you.

Now Microsoft have improved things. If your computer is associated with an MS account, you can simply use the activation troubleshooter, pick your device off the list and Bob's your Mum's brother. Except when it isn't listed. If I log into my MS account through a browser, there's my PC listed as one of the devices associated with my account. I think it's pukkah too: a Windows 7 device, full retail license, upgraded legitimately to Windows 10. However, if I go via the activation troubleshooter, it isn't listed. All my other devices are there, including some that don't exists anymore. So my next step is MS support. After the usual attempt to fob me off with totally unrelated web-articles and topics, I'm waiting for a call-back. No idea when. If it ever comes, and I won't be amazed if it doesn't, it will probably be while I'm in bed, or out walking with no access to pen, paper, or PC.

I suppose I don't actually need a license. I'll still get updates, it will still work fine as a Plex and backup server. And as I run it headless nearly all the time, I don't care about nags either. 
From: CHYRON (DSMITHHFX)22 Jan 18:53
To: william (WILLIAMA) 8 of 22
If you need a cheap license, worked for me last month for Win10.
From: william (WILLIAMA)22 Jan 23:46
Thanks. I've actually got a spare license I bought for something else that never materialised, so I may use that to keep things tidy. Having had no call back yet, I went on a google road trip to find out. The fastest I found was an hour. The slowest (apart from never) was 7 weeks. There's no contact route other than general phone numbers for your region. And that's for "free" support. Came across people shelling out £500 for one-off support requests and then... nothing, nada, for days, weeks. 
From: CHYRON (DSMITHHFX)23 Jan 00:39
To: william (WILLIAMA) 10 of 22
Ugh. I can't imagine paying for it.
From: william (WILLIAMA)23 Jan 18:14
You get what you pay for - or in this instance a little less. I'm fairly certain that according to the detail of the MS licensing arrangements I can make major changes to my PC and still reactivate it. It gets tricky in two areas. 1) the digital license from accepting a free update from Win 7 and later to Win 10 is not transferable. So if you do make changes, it's the story of the broom with two new brushes and one new handle. It seems there's an internal policy. Change your motherboard etc once. That's OK. Do it twice and you'll probably have to go through the phone route. This may explain why my PC isn't listed on the activation server, but is listed on my MS account. (I swapped in an identical ancient mobo a year or so back and it reactivated fine). The internal policy apparently is that after 5 hardware changes, major or otherwise, they'e going to start muttering, and may well argue that you're doing a transfer. 2) The other tricky area is that at the level of MS support I'm likely to encounter, I probably know as much in most areas, and more in others than they do., and it's very likely that I'll get refused a reactivation on the grounds that the provided method doesn't work, so I must be wrong. 
Anyhoo, I can't be arsed with all this so I'm going to update from Win 10 home to Win 11 pro as there are some extra bits I'd like to play with.
From: william (WILLIAMA)24 Jan 12:17
To: william (WILLIAMA) 12 of 22
Upgrade to 10 pro took under 5 minutes, now downloading 11 pro (still a free update). 12 is on the horizon. Wonder if that will be a free update.
From: CHYRON (DSMITHHFX)24 Jan 13:28
To: william (WILLIAMA) 13 of 22
Pretty sure most users get Windows through single-use disposable computers (tossed when the slightest problem or perception of slowness manifests). Buying retail copies is where it can get expensive, unless you go to the dodgy dealers.
From: william (WILLIAMA)24 Jan 19:29
Here's a bit of fun. Couldn't install Windows 11 because my system disk is MBR and not GPT. So I tried a partition manager, AOMIE, to convert it. System now unbootable. Anyway, I've got backups of all I need so I thought, clean install time since it's what I should have done anyway. So I stick in a Windows 10 installation USB stick and boot from it. Lo and behold, my Windows 10 pro starts instead of the installer. It's like it's using the USB bootmgr to get to start Windows on the C Drive. In fact that's all it does. It refuses to go to the installer menu.

So I wipe the boot disk. Does this help? Not really. It still tries to load - something. Anything but the installer. Eventually when I elect to "use another operating system" I get to the installer. Will it work? No. It looks like I have to pull all the drives except the target.


From: william (WILLIAMA)25 Jan 12:52
Looks like the problem was the partition manager (AOMIE). Not sure how it fucked the drive, but at least one thing it did was to leave it set to MBR, which in my view is below the minimum requirement for a partition manager's "convert to GPT" function.

From: CHYRON (DSMITHHFX)25 Jan 16:35
To: william (WILLIAMA) 16 of 22
Yeah the GPT/MBR thing is a Win 11 deal-breaker for me, also the TCM thingy, which I haven't activated on my ~5-yo motherboard because multiboot hassles. Everything I read about 'converting' a drive from MBR to GPT indicated the drive would be effectively wiped.

I accidentally formatted a pair of drives for a RAID 0 to GPT, which seems to work ok, but fdisk complains every time that the "primary GPT table is corrupt, but the backup appears OK, so that will be used." After some googling about it, I concluded let sleeping dogs lie.
From: william (WILLIAMA)15 Feb 11:47
Anyhoo, my main takeaway lesson, from this and the "phantom disk" thread, is to beware of false economy.

I had a decent Plex server running for 3 to 4 years using >10 yo bits which was fine. However, when this started to go wrong, penny-pinching made me invest in a large number of ineffective remedies to try and rescue what I had. I now have a decent Plex server on a modern(ish) AM4 board with a Ryzen 3, 16GB of DDR4, enough disk space for the time being, and a new (very old design) Coolermaster case. This should last a while. The downside is that the ancient case design means that the cabling is a total rat's nest. Plus I have a semi-operational SATA card and no obvious way to expand.

If I'd just bitten the bullet straight away, I could have bought something like the much better MSI PRO B550M-VC WiFi motherboards, which has 8 SATA ports and 2 M2 slots, all of which can be used, and a fabulous case like a Fractal Design Meshify 2. When I include things like cables, brackets, case fans (included with the Fractal Design case) etc etc , I'd probably still have change from what I spent.

*Also, I wouldn't have tried to cram everything into the original case, causing a plastic tab to snap off one the SATA drive data connectors so that I now have one drive with a cable that has to stay in place and not be knocked or shaken or the drive stops working!
From: ANT_THOMAS18 Feb 09:45
To: milko 18 of 22
Go laser. Colour lasers are a reasonable price these days.
Won't get away from the connection issues (though getting network printer might help), but god they're better. Toners don't dry out from infrequent printing. Just run and run.
From: william (WILLIAMA)18 Feb 11:37
To: ANT_THOMAS 19 of 22
It's a thought. They look as though they're getting better at photo-prints as well, although from what I've seen they can be a pain to set up for this. But most of our printing is documents anyway.
From: ANT_THOMAS18 Feb 14:23
To: william (WILLIAMA) 20 of 22
I fairly recently got a "broken" Brother B&W laser printer off Facebook marketplace for free. Owner said they couldn't connect over Bluetooth/WiFi, app didn't work, cable wouldn't connect.

A quick search told me it wasn't a smart printer in any way shape or form, so attempting a wireless connection was a pointless endeavour anyway.

USB socket was bollocksed. Removed that and soldered an old cable directly to the PCB and it's running perfectly now.

I did buy some replacement USB sockets but that would mean taking it apart again, and my bodge job with the cable is still working. So they're in a drawer waiting to never be used.