PCs are a pain

From: william (WILLIAMA)26 Jan 16:50
To: ALL1 of 11
So, half of my films suddenly disappeared from Plex. A quick check on the network and one of the drives in my Plex PC was missing. Not one of the smaller 3TB drives. Oh no, it had to be one of the 8TB drives. I mean, luckily, my strategy is to back up overnight, so I have another 8TB drive which is identical and I can be back watching films in 5 minutes. But then there's the nuisance of RMAing the drive with Amazon, who will shrug it off to Toshiba, who (in my experience) are a bit of a pain with warranty claims (it's only 4 months old). Anyway, the event log is full of disk events, mainly ID 51 (paging errors) and odd ID 157s (Disk 5 has been surprise removed) which I hadn't seen before plus a few bitblocker errors (I don't use it). After a couple of restarts, the disk was back. Chkdsk said it was fine. Its SMART status was fine and there were no SMART errors. Swapping SATA cables was a bit inconclusive, but at one point the "good" 8TB drive went AWOL too (back now). The "bad" drive didn't stick around for long, disappearing as soon as I pointed Chkdsk at it again. But then it was solid as a rock with no errors when I disconnected the "good" drive. But I tried the same trick again and it didn't work. I'm beginning to wonder whether it's actually a problem with SATA ports or controllers. Or even a PSU weakness.

Whipped it out (nj) and stuck it in a USB dock. Looking at it from another PC, it's perfect. All files present and correct, no CHKDSK errors, SMART all tidy and correct. Chkdsk with /B flag to check and recheck for any bad clusters is looking clean so far. A full HDDScan SMART test is next, but I'll have to put it on a SATA cable because via this USB dock that could take days.

So yeah. Bloody PCs.
From: CHYRON (DSMITHHFX)26 Jan 18:38
To: william (WILLIAMA) 2 of 11
Is this one of those newfangled "shingled" (SMR) hdds?
From: william (WILLIAMA)26 Jan 19:14
To: CHYRON (DSMITHHFX) 3 of 11
Apparently not, according to Toshiba. It's an X300 which is CMR.
From: Dave!!26 Jan 19:20
To: william (WILLIAMA) 4 of 11
Fun and games! When I build my current PC, it originally had an MSI motherboard which had a fault with the SATA system. One of my data disks kept disappearing and after eventually proving it was the board at fault rather than the disk, I was able to send it back and replace it with a Gigabyte board which (so far) has been solid.

Anyway, I feel your pain with trying to diagnose intermittent issues like this. The fault I had took several days of testing, swapping and head scratching until I confirmed what was playing up.
From: william (WILLIAMA)26 Jan 22:53
To: Dave!! 5 of 11
Even though it would cost more if I need a new board, it would be preferable to the hassle of trying to get a replacement drive. But I do need to know what the issue actually is. 

The motherboard is an Intel DQ57TM, LGA1156. It has a Stone Refurb bios, so probably came from an office refresh, but I bought it from somewhere else so it's almost certainly 3rd hand and probably dates back to when the boards were first made 12 years ago. That said, it's been rock solid since I got it.

It probably doesn't help that I have a lot of drives. Maybe I'll work out how to diagnose the problem. Maybe not.

I have just had a thought, I wonder if the last massive Windows 10 update package had something to do with it. I had a boot drive disappear once after an update.
From: william (WILLIAMA)27 Jan 15:03
To: ALL6 of 11
Well, the motherboard's SATA system has problems, in particular the internal e-SATA port that the drive was plugged into, although there have been a few other weird issues that I think are related. The drive itself has come though a complete surface scan and a full SMART scan with no problems. On the other hand, the bios reports that the SATA port is "not installed" which seems fairly conclusive. That said, the "not-installedness" is a bit hit and miss, as I can see errors and warnings in the event log relating to the drive plugged into it.

So, I'm going to limp along using the port previously given to the blu-ray drive until I can source a replacement board. Hey Ho.

Edit: except that didn't work. It seems that this motherboard won't mother this HDD on any port and via any cable. So now I have it attached in an external caddy and it works fine and sits just where it did before in the drive set-up. Maybe it is buggered after all - at least with a SATA connection. Although all the caddy does is provide a standard SATA socket and pass the data through the USB bus.
EDITED: 27 Jan 21:44 by WILLIAMA
From: william (WILLIAMA)28 Jan 15:10
To: ALL7 of 11
The drive, that has been cruelly rejected by my Plex box, works perfectly as a SATA attached drive in my main desktop PC. It also works perfectly as a USB attached drive in the Plex box. It's brother, an identical (or so I thought) Toshiba x300 8TB, works perfectly in any socket on the Plex box, and any cable.

I've heard of motherboard drive controllers and channels going wrong, but I've never heard of them developing a grudge against a particular device.

If I can't find anything to fix it, I shall attach it as an internal USB 3 device with one of these, or similar. I can snip the power cable and attach it to the 12V & GND pins from a Molex. That
way it will reboot with the rest of the drives.

Probably get it finished just in time for the motherboard to fail altogether. 
 
From: CHYRON (DSMITHHFX)29 Jan 13:01
To: william (WILLIAMA) 8 of 11
I've had several drives that ceased working after a while (usually >2-years), when directly attached via sata or pata motherboard plugs, but work fine in usb enclosures.
From: koswix29 Jan 14:48
To: william (WILLIAMA) 9 of 11
I had my first BSOD in aaaaages yesterday, by plugging in an SD card that had been corrupted by a bad Raspberry Pi. One corrupted card completely brought down the OS as the disk management service got stuck trying to interpret it and ignored all other requests. 

Had to disable automount in diskpart in order to access the card and delete the partitions, after which the card worked fine again. 

So yeah, bloody PCs are a pain in the hoop.
From: william (WILLIAMA)29 Jan 17:16
To: CHYRON (DSMITHHFX) 10 of 11
Yeah, looking around t'interweb, it seems to be a "thing". Thing is, this drive has now passed a ten hour checkdsk scan and an almost as long SMART scan (HDDScan), and it works perfectly in two different SATA slots on a different, newer, PC. As far as I know, it's only in the old PC with it's 11 year old mobo that it can't be seen. But that said, 4 other drives and a DVD drive work fine, in any slot. So there's obviously something about this particular HDD that stops it shaking hands. And it's something that happened over the weekend.

I've stuck on the latest BIOS and chipset drivers, but without any improvement. It's working OK through USB, and there's a card in a PCIE slot giving USB3 with a spare socket, so I'll mount it inside but connect it via USB.
EDITED: 29 Jan 17:23 by WILLIAMA
From: william (WILLIAMA)29 Jan 17:22
To: koswix 11 of 11
Yeah, that is SOOO annoying and a real issue with Windows: the way one misbehaving process can hang or crash the entire OS, and there's no way to kill it.