X99 motherboard not showing all RAM

From: milko 4 Feb 18:02
To: ALL1 of 12
Hello. Since we're being all 'a bit more active' suddenly.

I've recently switched my motherboard, CPU and RAM, I bought some second hand stuff for a nice price.

Asus X99 deluxe motherboard
Intel I7 5960x 3GHz but happily overclocks to 4.0 by all accounts
32GB tbh RAM in 4x 8GB DIMMS

And, it only seems to detect 2x of the DIMMS, for some reason. CPU-Z can see all of them, but BIOS and Windows only detect 16GB. 

Looking around the net, this doesn't seem that uncommon. It's just that all the people trying things out appear to know their way around arcane BIOS settings so they just off-handedly say 'do this; try that' and I have no idea how to actually do it. One of the ideas is that tehforum fave, of increasing the voltage to the DIMMS a little bit. But the current settings don't let me edit that value!

Does anyone have an idiot's guide to this stuff. 
From: Matt 4 Feb 18:12
To: milko 2 of 12
Have a look in the BIOS for a "Memory Remapping" option. It should be turned on for Windows to be able to use all the RAM installed in the system.
From: milko 4 Feb 18:15
To: Matt 3 of 12
the BIOS isn't seeing the other DIMMs either though. But I will check for such an option, thanks!
 
From: milko 4 Feb 18:29
To: milko 4 of 12
i cannot find such an option. There are pages of really techy looking things and none of them say memory remapping or memory extension that I can see. Augh.
From: milko 4 Feb 18:36
To: milko 5 of 12
oh, where the BIOS *does* see them is in "ASUS SPD Information" whatever that is. 

In slots A1, B1, C1 and D1 I have an Avexir 8GB DIMM. however it's only in A1 and B1 that it seems to pull all the details up correctly, C1 and D1 don't fill all the information. But A2/B2/C2/D2 which are empty come back with completely empty pages, so it's not like it doesn't know something's there.
From: Matt 4 Feb 18:43
To: milko 6 of 12
Looks like the X99 didn't have a memory remap option. My bad.

I would check you have the DIMMs installed in the correct sockets. ASUS uses (IMO) a really unintuitive naming convention for their memory sockets in the schema A1, B1, etc. which can be confusing.

As you have 4 DIMMS they should all be installed in A1, B1, C1 and D1 and not A1, A2, B1, B2 as you might think.
From: Matt 4 Feb 18:44
To: milko 7 of 12
Have you tried switching them around incase the DIMMs are bad?
From: CHYRON (DSMITHHFX) 4 Feb 19:35
To: Matt 8 of 12
He did install A1-B1-C1-D1, I suspect he needs to to try A1-A2, B1-B2.

Edit. Ah nope, A1-B1-C1-D1 is recommended per x99 manual... maybe check all dimms are the correct spec and matched? Did they come with the bundle and supposedly working with it?

From the ASUS support faq:

Memory isn't detected

6. Please clear CMOS first and check if memory is detected
EDITED: 4 Feb 19:46 by DSMITHHFX
From: CHYRON (DSMITHHFX) 4 Feb 20:51
To: milko 9 of 12
https://forums.tomshardware.com/threads/ram-not-fully-detected.2004456/

A lot of similar complaints here... the only practical suggestion is the last one: check the cpu for bent pins:
 
Quote: 
I had a similar problem when I reseated my i7-5930K. A bit of plastic debris hit one of my pins, so the RAM on DIMM_C1/D1 was not fully registering in the BIOS. My BIOS would only detect 8GB or 16, and the sticks would show up in BIOS reading "(Blank) GB, (Blank) Hz". Windows only recognized 8GB, but CPUID would show 16GB as being plugged in.

Switching the sticks did nothing. as the sticks were all perfectly fine, it was a bad pin (or pins) that weren't reading DIMM_C1/D1.

I recommend reseating your CPU and checking for any lint/dirt/debris or bent pins.
From: milko 4 Feb 20:53
To: ALL10 of 12
Everything came ready-seated apart from the cooler, I had a lot of long-story fun and games with that too. I trust the seller and that it was working for him.

Tried a few different BIOS settings today, nothing major. Nothing changed anything, so I put 'em back. Then I remembered this switch on the board which enables the TPU - I'd turned that off during earlier woes but the original owner had it enabled originally. Anyway, since it effects overclocking I figured why not try and enable it, the temps are all nice and low it might even solve the RAM thing. 

It wouldn't even get to BIOS. Erk! I set it to the middle setting, and again no good. I turned it back off, and I still can't get the fucker to boot. Fucking hell, computers. Resetting the CMOS via the switch didn't help either, it would get part way through the boot and then seem to hang, but not always in the same place or with the same Q-code. So I pulled the battery for half an hour and then fired it back up.

It got to BIOS. More weirdly still, it shows 32GB RAM!

I enabled the XMP setting again since the reset had turned that off. It still shows 32GB RAM! And in Windows!

I think that probably means DSMITH is the prize winner, it's just a shame I solved it myself before I read that :)

I did try all that reseating the CPU stuff yesterday having read the same forum posts, it didn't help me.
EDITED: 4 Feb 20:54 by MILKO
From: graphitone 5 Feb 09:34
To: milko 11 of 12
Is it still stable, after reboots and a total power off?
Might be worth looking around for an updated firmware for the board. There was one site that I found really useful when sticking a custom firmware onto my ageing board which I needed to get a recent GPU upgrade working. I'll post the link if I can find the site again.
From: milko 5 Feb 11:34
To: graphitone 12 of 12
seems fine now. Firmware was all up to date. I guess it just really really needed the CMOS battery reset for some obscure computers reason. Next thing to try is overclocking a lot!