IBM System X

From: koswix 3 Feb 2020 00:35
To: ALL1 of 22
Seeing as there's suddenly people here for some reason...

Anyone have experience with IBM System X servers? I've got a x3100 that's poorly. Was working fine running Ubuntu until it had a weird crash the other week (disappeared off the network, unresponsive to ping or SSH, but samba shares still working fine).

When I shut it down it refused to restart. I can get as far as the BIOS every 3 boots (think that's a failsafe mechanism), but looks like the IMM has died. Lots of 'can't communicate' errors in the log, and the wee LED that flashes to say the IMM is loading never stops flashing. I've tried the backup BIOS and backup IMM jumpers but with no joy.

Anyway to flash a new IMM firmware without being able to boot the machine? Any other ideas worth trying? I've done the usual remove everything, reseat everything etc. 

Kinda disappointed if it's totally dead, this thing cost me the best part of £31 on ebay, I really expect more than 18 months service from my obsolete servers.
From: Kenny J (WINGNUTKJ) 3 Feb 2020 09:20
To: koswix 2 of 22
I can see why, having spent so much on it, you want to repair it possible. I'm not overly familiar with the system, so let's try the basics first:

Have you tried increasing the voltage on the AGP Port?
From: koswix 3 Feb 2020 11:09
To: Kenny J (WINGNUTKJ) 3 of 22
Ah, well I did think of that but there's no agp slot.

I did temporarily increase the voltage to the PSU, from 230V AC to 415V AC. That was a few weeks before it died, do you think it could be related?
From: Kenny J (WINGNUTKJ) 3 Feb 2020 11:13
To: koswix 4 of 22
Depends - what colour was the smoke that came out? I'm assuming smoke came out.
From: william (WILLIAMA) 3 Feb 2020 11:20
To: koswix 5 of 22
looks fairly simple from the IBM manuals. You try recovery using the backup IMM start code by means of the IMM backup jumper 
If the IMM starts up successfully, follow the remaining steps to finish the recovery procedure. Otherwise, replace the system board

You aren't helped by the fact that even if you could flash the IMM firmware it looks as though you need an activation key.
From: koswix 3 Feb 2020 11:25
To: Kenny J (WINGNUTKJ) 6 of 22
Didn't see what colour, server lives in the loft.

The smoke from my AV receiver was acrid grey, if that's any help.
From: koswix 3 Feb 2020 11:27
To: william (WILLIAMA) 7 of 22
New board on eBay is £150 T-T

I think you only need the code/license for the advanced features? The basic functionality should just work, I think.
From: william (WILLIAMA) 3 Feb 2020 11:37
To: koswix 8 of 22

£150 vs £31

Are you tempted? Pity you've just had your birthday, haven't you?
From: william (WILLIAMA) 3 Feb 2020 12:01
To: koswix 9 of 22
I didn't bother digging very far because it started to remind me of work so I got all panicky and cold-sweaty and stopped, but what is the flash procedure? I saw that there's a web method (which seems a bit dumb, at least in an emergency, since the IMM controls the network).

We had a little server room at the end of the corridor with a rack of switches and some servers. There was an ancient free-standing server that had been running for years but nobody knew what it was because it wasn't on any network plans and the sticky label had dropped off. Some Network people were mucking about with re-routing some new staff workstations and one of then decided to reboot it using the big button on the front. I did suggest that plugging in the spare monitor that was standing about a foot away just to check first might be clever, but that earned me a sneer. That wouldn't restart either. turned out to be something crucial to do with Stamp Duty. Cost more than £150 on ebay to rebuild.
From: koswix 3 Feb 2020 12:30
To: william (WILLIAMA) 10 of 22
The flash procedure seems to be "do it via the the web interface, if the IMM won't load, boot the backup IMM and do it via the web interface".

As far as I could see in the manual, if the backup IMM won't load either, replace the motherboard. Surely must be a header somewhere I could flash from, though?

Struggling to find any cheap replacement boxes on eBay, thankfully it's just a Plex and file storage server of little consequence to anything mission critical - glad I'm not trying to explain to the bean counters why the beans are no longer being counted.
From: CHYRON (DSMITHHFX) 3 Feb 2020 15:10
To: koswix 11 of 22
No chance it's the CMOS battery?
From: koswix 3 Feb 2020 15:20

Would surely still boot, just lose its BIOS settings? I've taken battery out and cleared CMOS to no effect.
EDITED: 3 Feb 2020 15:24 by KOSWIX
From: CHYRON (DSMITHHFX) 3 Feb 2020 15:53
To: koswix 13 of 22
Re-seated ram, add-in cards, different psu yadda?. We're in hail-mary-pass land now... (I didn't know you could oc a psu?)
From: koswix 3 Feb 2020 15:57
Tried all that (don't have bother PSU to try).

Didn't OC the PSU so much as accidentally blow up half my house due to 1950s electrics going wrong
From: CHYRON (DSMITHHFX) 3 Feb 2020 16:07
To: koswix 15 of 22
I've had a pc that wouldn't post until I pulled the hdd. Then it would post, boot from a cd, and ultimately from a new hdd.
From: Matt 3 Feb 2020 19:25
To: koswix 16 of 22
Probably the PSU then.

Get your Multimeter out and measure the outputs of the 12v and 5v rails on the PSU motherboard connector and see what it is giving out.
From: william (WILLIAMA) 3 Feb 2020 22:29
To: koswix 17 of 22
...with a paperclip shorting pins 15 & 16 (green and black) natch
From: koswix 4 Feb 2020 08:56
To: Matt 18 of 22
Will check at the weekend.
From: CHYRON (DSMITHHFX) 4 Feb 2020 14:02
To: william (WILLIAMA) 19 of 22
Worked for me!
From: william (WILLIAMA)13 Feb 2020 23:34
To: koswix 20 of 22
So, what happened?