Diagnosing disk issues from fsck output

From: CHYRON (DSMITHHFX)28 Aug 2017 13:51
To: ALL1 of 6
I'm been having some hdd problems with my main Fedora 19 system starting during the weekend. The pc has frozen a couple of times after running for some (6-8) hours, but rebooted after. However a couple of other times after a 'normal' shutdown it wouldn't reboot until I ran e2fsck on it (via gparted) from a systemrescuecd.

Here's a truncated report with some example errors (all errors were fixed):
calibrate /dev/sda12  00:00:03    ( SUCCESS )
path: /dev/sda12 (partition)
start: 1058796018
end: 1140711389
size: 81915372 (39.06 GiB)
check file system on /dev/sda12 for errors and (if possible) fix them  00:00:12    ( SUCCESS )
e2fsck -f -y -v -C 0 /dev/sda12  00:00:12    ( SUCCESS )
Superblock last mount time is in the future.
(by less than a day, probably due to the hardware clock being incorrectly set)
Superblock last write time is in the future.
(by less than a day, probably due to the hardware clock being incorrectly set)
Pass 1: Checking inodes, blocks, and sizes
Interior extent node level 1 of inode 655992:
Logical start 4635 does not match logical start 4685 at next level. Fix? yes

Inode 655992, end of extent exceeds allowed value
(logical block 6472, physical block 6177248, len 16)
Clear? yes
[followed by ~couple dozen blocks in the inode with same error, and other errors for this and other inodes listed separately, e.g.:]
end of extent exceeds allowed value
extent tree (at level 2) could be narrower
i_blocks is 139856, should be 125784
extent tree (at level 1) could be narrower
Deleted inode 1573357 has zero dtime
Inodes that were part of a corrupted orphan linked list found
Failed to optimize extent tree <655992> (655992): Extent not found
Block bitmap differences: -(73225--73235)
Free blocks count wrong
Free inodes count wrong

And summarized thus:

fc19: ***** FILE SYSTEM WAS MODIFIED *****

313209 inodes used (12.22%, out of 2564096)
1951 non-contiguous files (0.6%)
254 non-contiguous directories (0.1%)
# of inodes with ind/dind/tind blocks: 0/0/0
Extent depth histogram: 298862/197/8
8409120 blocks used (82.12%, out of 10239421)
0 bad blocks
3 large files

Hopefully "0 bad blocks" in the summary is significant (?) The hdd passed a smartmon quick test with no errors reported. While I had it running from systemrescuecd, I was able to do a backup of recent work to another pc.

The issue apparently arose after I began editing some larger files in GIMP (I recently acquired a new photo scanner), along with running gThumb and Firefox in a memory-constrained (2 GB) environment. This also causes frequent slowdowns and swap thrashing, although so long as I remember to quit out of firefox the slow downs and disk thrashing go away. Apparently fs errors are being introduced by this stress, unless it is just a coincidence.

I have suspected other factors including MB traces damaged during original assembly, and/or (possibly related) ata bus issues. I've had the pc for ~5 or 6-years and it was a cheap-ass msi microATX design that supported my AGP video card

Anyone care to venture a guess as to what is going on with my hdd?

Maybe I just need a new pc  :-D I do have a spare new hdd on standby but either way I'd be looking at a full reinstall :-( which I would like to put off  :-/ .

EDITED: 28 Aug 2017 13:53 by DSMITHHFX
From: Manthorp28 Aug 2017 20:46
My first instinct is that you're looking too deep. Clean the crap out of your cooler fins & fan grills. Maybe take off a side panel. Sounds like overheating to me.
From: CHYRON (DSMITHHFX)29 Aug 2017 01:01
To: Manthorp 3 of 6
Not likely, but worth a blow job (nj). Side panels been off for years, hdd is outside the case and doesn't seem overly hot.
From: CHYRON (DSMITHHFX)29 Aug 2017 15:18
To: ALL4 of 6
Clean boot and (apparently) shutdown this morning. My suspicion now points to a FF memory leak maxing out the swap file over time, preventing a clean shutdown or (eventually) causing a hard crash. xp appears to be unaffected and has carried on as per usual.

This may help: https://addons.mozilla.org/en-US/firefox/addon/ramback/
EDITED: 29 Aug 2017 15:22 by DSMITHHFX
Message 42016.5 was deleted
From: CHYRON (DSMITHHFX)20 Dec 2021 11:20
To: ALL6 of 6
Disk issues, or file system issues?


Oh. zombie thread.  :-$
EDITED: 21 Dec 2021 15:46 by DSMITHHFX