Odd connection issue

From: ANT_THOMAS13 Feb 2017 20:20
To: ALL1 of 24
It's not the bathroom light (AFAIK)

My cheapo VPS that I've been using as an OpenVPN server has been ticking along nicely until today.

I noticed an odd issue where I tried to access a page on my home server which loads fairly large images whilst I was connected to the VPN and it would load about 5% of the image then fail, and the connection to that server/IP would also fail (ssh connection open in the background died).

I've since logged in to the VPS over ssh as I figured out it was that rather than my home server that was the issue.

If I try and download anything (wget or apt-get upgrade) the connection drops out around 250-300 KB into the download, then I can't retry whatever URL for around 5 mins.

Any ideas?
From: graphitone13 Feb 2017 20:33
To: ANT_THOMAS 2 of 24
Any idea where the VPS is? Countrywise that is. 'Cos if it's North Korea I think I can explain those download speeds. :|
From: ANT_THOMAS13 Feb 2017 20:35
To: graphitone 3 of 24
London, a bit crap I know :C
From: ANT_THOMAS13 Feb 2017 21:55
To: ALL4 of 24
Interesting... (or not)

Downloading over IPV6 works fine.
SCP upload to the VPS also fails after a small amount of data.
From: graphitone13 Feb 2017 22:08
To: ANT_THOMAS 5 of 24
Your IPv4 settings don't have some strange non-duplexed options, or anything that could bog down the speed that aren't there on the IPv6 ones?

 
From: ANT_THOMAS13 Feb 2017 22:21
To: graphitone 6 of 24
Found out I can actually get technical support even though I only paid a few quid. Looks like there's DDoS issues on the host.
From: graphitone14 Feb 2017 09:05
To: ANT_THOMAS 7 of 24
Probably from North Korea.
From: ANT_THOMAS14 Feb 2017 09:09
To: graphitone 8 of 24
Trying to prevent my competing missile program.
From: graphitone14 Feb 2017 09:51
To: ANT_THOMAS 9 of 24
To be fair, with your 3D printer, you've got the technical advantage.
From: CHYRON (DSMITHHFX)14 Feb 2017 10:12
To: graphitone 10 of 24
They have lego.
From: koswix14 Feb 2017 10:22
To: CHYRON (DSMITHHFX) 11 of 24
*megablox
From: Serg (NUKKLEAR)14 Feb 2017 12:08
To: koswix 12 of 24
*Lepin Death Star actually. Shh, don't tell them about the thermal exhaust port!
EDITED: 14 Feb 2017 12:09 by NUKKLEAR
From: koswix14 Feb 2017 13:07
To: Serg (NUKKLEAR) 13 of 24
Classy.
From: Lucy (X3N0PH0N)14 Feb 2017 14:54
To: ANT_THOMAS 14 of 24
OpenVPN can choke weaker machines/connections with the encryption. It adds a fair overhead to everything. Assuming you're using the VPN to bypass bullshit laws rather than for privacy, you could turn encryption off (cipher none) and ideally use PPTP rather than UDP or other.
From: CHYRON (DSMITHHFX)14 Feb 2017 15:27
To: koswix 15 of 24
Damn. How did I miss this hive of international failed terrorist states right under my nose?

 
Attachments:
From: ANT_THOMAS14 Feb 2017 19:14
To: Lucy (X3N0PH0N) 16 of 24
Looks like it was some sort of DDoS protection kicking in. But that's a good tip anyway. I've seen very slow SCP transfers in the past on weak CPUs, where changing the cipher sped things up massively.
From: Lucy (X3N0PH0N)14 Feb 2017 19:26
To: ANT_THOMAS 17 of 24
Yeah, I use SSHFS for letting things see the storage of other things and disabled the encryption as much as possible cos why not on an internal network.

(Tried NFS but found it surprisingly flaky and *way* more complex to set up).
From: ANT_THOMAS14 Feb 2017 19:34
To: Lucy (X3N0PH0N) 18 of 24
Yeah definitely fine on an internal network.

Only played with NFS for one share after SMB was being odd. Always read about using NFS rather than SMB in all scenarios since it's supposed to be much quicker.
From: Lucy (X3N0PH0N)14 Feb 2017 20:40
To: ANT_THOMAS 19 of 24
Should definitely be better than Samba, yeah. And I liked it apart from it just flaking out every couple of days. Probably my fault but I couldn't be arsed spending much time sorting it out since I don't need 99% of its features - I just want super-easy access to files across the network and sshfs is kinda perfect for that.
From: ANT_THOMAS14 Feb 2017 21:09
To: Lucy (X3N0PH0N) 20 of 24
How are you mounting stuff? Via fstab?
I remember years ago having various issues with network shares dropping out mounted using fstab and having to do "mount -a" far too often. Then I moved to autofs and it fixed all issues. If you're already using it then no idea, if you're not it might be worth playing with.

Or stick with sshfs since it works!