Debugging CIFS / samba on Windows

From: Peter (BOUGHTONP)18 Jun 2016 15:14
To: ALL1 of 52
Windows has decided to stop being able to access the shares on my NAS. (I get the error "Windows cannot access \\assbox\stuff")

The samba service is running and working on the NAS, and I can get the list of shares via a Linux machine with smbtree - none of which is a surprise, nothing changed on the NAS, it's Windows that's broken.

I can ping the NAS and connect to its web-based GUI so it's not a general network issue, it's something specific to accessing the CIFS shares.

Searching is useless - I'm getting nothing on how to pinpoint what the issue is on Windows. (There's a billion answers for Linux but I know that side is working.)

I did change networks stuff a couple of weeks ago for an unrelated issue (think I turned off IPv6 and probably other stuff I can't remember), and whilst I think I used the NAS since then I can't remember for sure.

I've turned IPv6 back on and been fiddling with HomeGroup stuff because that's related to file sharing, though I don't think I was in a HomeGroup before.

Any ideas what to try?

From: ANT_THOMAS18 Jun 2016 15:26
To: Peter (BOUGHTONP) 2 of 52
Tried using the IP rather than assbox?
From: CHYRON (DSMITHHFX)18 Jun 2016 15:58
To: Peter (BOUGHTONP) 3 of 52
What make is your nas? Did you check the mfg's (or other) forums to see if it's maybe a firmware issue?
From: Peter (BOUGHTONP)18 Jun 2016 16:35
The NAS works fine; it's a Windows issue.
From: Peter (BOUGHTONP)18 Jun 2016 16:38
To: ANT_THOMAS 5 of 52
Same error with IP address.

Though the error dialog does come up straight away with the IP - using the hostname it takes a while (though it's in my hosts file so not sure why there'd be a difference).

From: graphitone18 Jun 2016 20:17
To: Peter (BOUGHTONP) 6 of 52
I was gonna suggest DNS 'til I got to that bit. :(

What are the permissions on the share? I'm not very good with Linux, but does it have an ACL you can tweak?
From: Peter (BOUGHTONP)18 Jun 2016 21:32
To: graphitone 7 of 52
The permissions on the share are the same as they were before, because the problem is not with the NAS, it's something on the Windows side.
From: graphitone18 Jun 2016 21:59
To: Peter (BOUGHTONP) 8 of 52
Gotcha - misread the bit up there. Hmmm, any recent Windows updates?

Is Windows Network Discovery on?
EDITED: 18 Jun 2016 22:02 by GRAPHITONE
From: Peter (BOUGHTONP)18 Jun 2016 22:09
To: ALL9 of 52
Ok, so I have an actual error message now
C:\Users\Peter>net view \\
System error 53 has occurred.

The network path was not found.
Again, I can ping the machine:

Pinging with 32 bytes of data:
Reply from bytes=32 time<1ms TTL=64
Reply from bytes=32 time<1ms TTL=64
Reply from bytes=32 time<1ms TTL=64
Reply from bytes=32 time<1ms TTL=64

Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
Searching for "System error 53 has occurred" leads to this page which lists the following:

1) if it is domain environment, check your WINS;
2) if it is peer-to-peer workgroup, enable NetBIOS over TCP/IP;
3) make sure the machine is running;
4) make sure file and Printer Share enabled on remote computer;
5) make sure client for ms networks is enabled on local computer;
6) make sure you type the correct name.
7) Make sure no firewall running or any security setting.

1 doesn't apply, 2 didn't work, 5 is enabled, toggling firewall made no difference.

I'm currently thinking it's got to be something in Local Area Connection Properties and/or TCP/IPv4 properties - something I inadvertently changed and whatever configuration I try I can't find the magic values that it had before. :(

From: graphitone18 Jun 2016 22:14
To: Peter (BOUGHTONP) 10 of 52
<replied to the wrong thread>

If you've altered something in the IPv4 settings can you show us the output of an ipconfig/all
From: Peter (BOUGHTONP)18 Jun 2016 22:14
To: graphitone 11 of 52
Nope, no recent Windows Updates applied.

Network discovery is on.

From: Peter (BOUGHTONP)18 Jun 2016 22:30
To: graphitone 12 of 52
There's a whole bunch of tunnel adapter bollocks included, which is in the attached file in case it's relevant, along with the wireless adapter output, which is using 192.168.43.x and shouldn't be affecting things?
Windows IP Configuration

   Host Name . . . . . . . . . . . . : Storm
   Primary Dns Suffix  . . . . . . . : 
   Node Type . . . . . . . . . . . . : Mixed
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection:


Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 00-90-F5-9B-5A-57
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Autoconfiguration IPv4 Address. . : 
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . : 
   NetBIOS over Tcpip. . . . . . . . : Disabled
From: Peter (BOUGHTONP)18 Jun 2016 23:44
To: ALL13 of 52
I setup a WebDAV share and can access that from Windows, though it needs to be mapped to a drive letter and seems ridiculously slow - simply opening a text file can take a couple of seconds. :/

Accessing NFS shares on Windows seems like a minefield, and there's an iSCSI option but that seems to have so much configuration... :&

So if I can't figure out WTF is stopping CIFS connecting then that leaves me with FTP. :'(

From: CHYRON (DSMITHHFX)19 Jun 2016 01:01
To: Peter (BOUGHTONP) 14 of 52
Have you tried accessing it from a different Windows pc?
From: Peter (BOUGHTONP)19 Jun 2016 01:27
I was accessing it from this Windows PC one a month ago, and it was working perfectly.

Regrettably I don't know of any protocols that possess the appropriate temporal aspect to let me record all the settings and changes made before things got screwed up.

From: graphitone19 Jun 2016 07:29
To: Peter (BOUGHTONP) 16 of 52
You've got an apipa on the Ethernet connection and a class b subnet, I take it you're using the wireless to connect from the windows machine to the network, it shouldn't make a difference but have you tried disabling the Ethernet adapter?
From: Peter (BOUGHTONP)19 Jun 2016 12:31
To: graphitone 17 of 52
Nope, the wireless connection goes to the Internet.

The NAS is connected via Ethernet to the same switch as the Windows machine. (The NAS doesn't connect to wifi.)

From: CHYRON (DSMITHHFX)19 Jun 2016 14:47
To: Peter (BOUGHTONP) 18 of 52
Can you restore from backup to when it was working?
From: Peter (BOUGHTONP)19 Jun 2016 15:00
Only if you can supply me with a time machine so I can go back and create a restore point...
From: ANT_THOMAS19 Jun 2016 15:21
To: Peter (BOUGHTONP) 20 of 52
Turned off system restore?

Definitely don't have access to another windows system just to try?