Force delete app on non-rooted android

From: CHYRON (DSMITHHFX)16 Jun 2016 15:09
To: ALL1 of 9
A while ago (> year iirc) I installed "player fm" so I could listen to podcasts. Never used it. I opened it last week, and while trying to remember why I installed it (thinking "FM" === "music"), unintentionally* subscribed to a bunch of things by clicking on a seemingly generic news link. So it informed me that it would now start downloading crazy amounts of stuff every time I'm connected to wifi. A couple of days later when I noticed it doing exactly that, I tried to delete it. It doesn't want to be deleted. Instead, attempting to delete it causes my nexus 7/Android 5.1.1 tablet to reboot after a lengthy time (>10-minutes), which I've tried 3-4 times always with same result: long wait, reboot, no delete. :C The stupid app is only ~30MB. It does not have "device administrator" permissions.

Any pro tips on how to force-delete an app from an unrooted deviced?

*this may have been facilitated by alcohol

**oh, and I did figure out how to turn off the downloads, so there's that.
EDITED: 16 Jun 2016 15:13 by DSMITHHFX
From: ANT_THOMAS16 Jun 2016 16:10
What method are you using to try and remove it?
Is it rooted?
From: CHYRON (DSMITHHFX)16 Jun 2016 16:21
To: ANT_THOMAS 3 of 9
It's not rooted. I'm going through settings/apps/click on the app & choosing "uninstall".

The tablet seems to be spontaneously rebooting now every hour or so. I'm going to try and get into safe mode and see if I can delete the app there.
EDITED: 16 Jun 2016 16:22 by DSMITHHFX
From: ANT_THOMAS16 Jun 2016 16:27
I think it's possible to delete apps using adb if you have any idea how to use that?
From: CHYRON (DSMITHHFX)16 Jun 2016 16:28
To: ANT_THOMAS 5 of 9
I have adb set up, but I think I'll try safe mode first.
From: CHYRON (DSMITHHFX)16 Jun 2016 16:37
To: ALL6 of 9
Safe mode did it in about 2 seconds.

Then I was unable to delete any other apps, and it rebooted itself.
EDITED: 16 Jun 2016 17:02 by DSMITHHFX
From: CHYRON (DSMITHHFX)16 Jun 2016 18:46
To: ALL7 of 9
Hasn't rebooted since the app delete/reboot couple of hours ago. I installed "Bootlog Uptime" so I can track whether it is rebooting when I'm not looking. AFAIK this is/was completely new behavior (though it has spontaneously rebooted a few times since I got it ~3-years ago, usually after an OTA update).
EDITED: 16 Jun 2016 18:47 by DSMITHHFX
From: Manthorp16 Jun 2016 21:22
Soz (((Smiffy))), sounds like a pain in the bum. 

Reading through the post sequence, I was going to write something like 'leave it there, what's 30mb?' but or course neither I, nor you, nor any self-respecting geek would or could have ever done that.  Fuck knows how many hours - days indeed - I have spent wrangling stuff (and fucking bigger stuff up as a consequence) because it would be neater thus.
From: CHYRON (DSMITHHFX)17 Jun 2016 01:04
To: Manthorp 9 of 9
Yeah, my concern was that it was some kind of malware that had its hooks in me. Also, I was wondering if it were merely a symptom of some underlyiing issue, like old age even. Not that I would know anything about that. Anyways I got rid of it.
EDITED: 17 Jun 2016 01:07 by DSMITHHFX